Sommario
Nel presente articolo viene spiegato come verificare e risolvere il problema di attivazione di Perfetto4 causato dall'impossibilità del software di contattare il server di gestione della licenza.
Permessa
Per una corretta comprensione delle informazioni contenute nel presente articolo occorre avere prima consultato l'articolo Come attivare Perfetto4.
Sintomi
Il prodotto Perfetto4 non si riesce ad attivare e non si riesce ad aprire le sue maschere.
Provando ad attivare il software o provando ad aprire una sua maschera viene visualizzato il messaggio di errore:
Codice errore: [2]\nPertetto non riesce a contattare il server di gestione della licenza, verificare la connessione internet del server. \nL'uso di Perfetto è stato temporaneamente disattivato
in attesa che sia ripristinata la connessione internet
Causa
Il sistema di attivazione di Perfetto4 si basa su un ping di validazione scambiato tra il server dove è installato Perfetto4 e un server remoto di amministrazione delle licenze di attivazione.
Questa validazione dell'attivazione viene eseguita alla prima installazione\attivazione di Perfetto4 e in forma ridotta e periodica durante l'uso del software.
Il messaggio di errore descritto nel paragrafo precedente potrebbe essere determinato da limiti di comunicazioni nello scambio di validazione via internet, dovuti ad impostazioni di firewall, antivirus o configurazioni sistemistiche, volte a proteggere la rete aziendale, ma che effettivamente si possono rilevare bloccanti per il sistema di validazione di Perfetto4.
Non è assodato che la causa sia necessariamente dovuta a blocchi di comunicazione, ma è sicuramente un aspetto da verificare con la modalità descritta nel prossimo paragrafo.
Soluzione
In questo paragrafo, più che dare una soluzione, viene dato un metodo di verifica per determinare la possibile causa del problema, sulla quale verrà poi formulata la soluzione più idonea da attuare.
Eseguire questa sequenza di verifiche nell'ordine indicato:
- sul server dove è installato Perfetto4 verificare che sia attiva una connessione internet; se così non fosse ripristinare la navigazione internet e poi riprovare ad attivare Perfetto4;
- sul server dove è installato Perfetto4 controllare da browser internet che il sito https://license.antos.it sia raggiungibile, si deve visualizzare una pagina di login, dove non è necessario accedere, è sufficiente che la pagina sia visibile;
- verificare che il firewall di Windows sia disattivo o disattivarlo temporaneamente, se riprovando ad attivare Perfetto4 l'errore persiste, il firewall può essere riattivato;
- posizionarsi sul server dove è installato Perfetto4;
- posizionarsi nella cartella di installazione "C:\Program Files (x86)\Microarea\Mago4\Custom" (esempio di path di default);
- creare nel percorso un file di testo il cui nome deve essere identico a questo:
PrfLicLog.log
Importante è che l'estensione del file sia ".log" e non ".txt"; - eseguire l'attivazione di Perfetto4 e\o provare ad aprire maschere di Perfetto4, in questo modo il software scrive nel suddetto file tutte le azioni che esegue per la validazione;
- visionare il contenuto del file di log con un editor di testo alla ricerca di eventuali errori;
- se nel file di log è presente questo messaggio di errore:
2024/12/16 11:11:42: GetTokenWebException: Richiesta annullata: Impossibile creare un canale sicuro SSL/TLS..
2024/12/16 11:11:42: ReadFileAndPingLite: errore token
2024/12/16 11:12:16: GetTokenWebException: Connessione sottostante chiusa: Errore imprevisto durante un'operazione di invio..
2024/12/16 11:12:16: ReadFileAndPingLite: errore token
2024/12/16 11:13:01: licensing server irraggiungibile da 33024 minuti
allora la causa è probabilmente un firewall, antivirus o VPN di terze parti sul server o sul modem\router che impedisce il corretto e completo collegamento al server remoto di gestione della licenza di Perfetto4; - in questo caso occorre contattare il proprio Sistemista aziendale, spiegargli il problema e girargli le informazioni raccolte, in modo che possa intervenire sui software interessati e sbloccare il collegamento completo al server remoto raggiungibile all'indirizzo https://license.antos.it;
- poi riprovare l'attivazione di Perfetto4 e verificare che si attivi correttamente e che poi si possa utilizzare regolarmente le maschere del prodotto.
Come aiuto per verificare il contenuto del file di log è possibile farlo visionare al Supporto Antos per il prodotto Perfetto4 scrivendo all'e-mail assistenza@myperfetto.it.
Nota bene
Il file di log illustrato nei punti 5-6 del suddetto elenco viene sempre automaticamente popolato fino a quando rimane presente nella cartella "Custom" dell'installazione e se vi rimane per molto tempo, le sue dimensioni possono diventare elevate.
Si consiglia pertanto di cancellarlo una volta che il suo utilizzo non è più necessario.
Poi se dovrà essere nuovamente impiegato, sarà sufficiente ricrearlo con la stessa modalità sopra descritta.
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