Sommario
Nel seguente articolo viene illustrato come intervenire per correggere in Perfetto Orange/Yellow 3.14.12 nel caso si verifichi l'errore di apertura delle maschere delle procedure inerenti la fatturazione elettronica.
Sintomi
All'apertura delle maschere delle procedure inerenti la fatturazione elettronica (come ad es. l'Aggiornamento Stato Documenti o la Trasmissione Documenti che si trovano in [Comunicazioni Digitali>Fatturazione Elettronica]), viene visualizzato il messaggio bloccante "E' accaduto un errore imprevisto" e successivamente viene visualizzato il messaggio di generazione del Log dell'errore, come indicato nella seguente immagine.
L'errore è stato rilevato nell'utilizzo delle procedure sopra indicate in installazioni client di Perfetto Orange/Yellow 3.14.12, a seguito di una nuova installazione di Perfetto Orange/Yellow 3.14.12 sul server.
L'errore non è stato rilevato dopo l'installazione di Perfetto Orange/Yellow 3.14.12 a seguito di aggiornamento da versioni precedenti di Perfetto Orange/Yellow.
Cause
Il computer su cui è stato installato il client ha avuto un problema con la distribuzione ai client (deployment) dell'installazione di Perfetto.
Soluzione
Per risolvere il problema è necessario verificare che:
- sul server, aprire con i diritti di amministratore un Prompt dei comandi DOS
- eseguire il comando "ClickOnceDeployer UI" (senza virgolette) per aprire l'interfaccia grafica del ClickOnceDeployer
- selezionare l'opzione "Deploy" dal menù a tendina delle "Actions"
- premere il pulsante "Run"
Nota: se il problema non viene risolto, eseguire il "ClickOnceDeployer UI" con l'Actions "UpdateDeployment"
Commenti