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SOLUZIONE: La comunicazione con Perfetto è andata in Timeout. Assicurarsi che la connettività di rete sia disponibile e funzionante e che il server Perfetto sia raggiungibile

Sommario

Il presente articolo mostra come risolvere l'errore che impedisce l'uso dell'app di Perfetto a causa di un Time Out nel tentativo di contattare il server di Perfetto.NET/ERP o Perfetto 4 a seguito dell'indicazione errata del suo URL (Uniform Resource Locator) del server del server.

Sintomi

In fase di configurazione di un utente sull'app di Perfetto si riceve il messaggio di errore che avvisa che è impossibile eseguire la login sull'app in quanto la comunicazione con il server di Perfetto è andata in Time Out. 

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Causa

L'app di Perfetto per connettersi al server del gestionale utilizza l'indirizzo URL del server di Perfetto, tale URL deve essere indicato correttamente e completo di tutte le sue parti.

Tale necessità è descritta anche negli articoli:

Il messaggio di errore segnala di fatto l'impossibilità (nel tempo fissato) di stabilire una connessione tra il server e l'app di Perfetto; superato il tempo limite, l'app notifica all'utente il superamento del tempo a disposizione (Time Out).

Soluzione

Per prima cosa è necessario verificare che sia lo smartphone che il server di Perfetto siano collegati ad  internet e che lo smartphone riesca tramite browser web a consultare i siti internet. 

In seconda istanza è necessario verificare la correttezza dell'URL di cui si dispone, per farlo occorre:

  • aprire un browser internet (ad es. Google Chrome)
  • nella barra dell'indirizzo digitare l'URL del server di Perfetto (ad es. http://88.149.x.x/mago4 )
  • verificare che la pagina di "Installazione componenti client di Mago/Perfetto" venga mostrata.

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Se la pagina sopra indicata non viene mostrata, significa che il server non è contattabile dall'esterno dell'azienda tramite il suo indirizzo IP pubblico ossia che il server di Perfetto non è correttamente esposto su internet.
Per risolvere questa tipologia di problemi si consiglia di contattare il sistemista di riferimento per i dovuti controlli (ad es. se sul Firewall sono applicate le giuste regole per permetter la comunicazione con l'app, se l'indirizzo IP pubblico è stato correttamente configurato, ecc).

 

Dopo aver verificato la correttezza dell'URL è necessario indicarlo in modo corretto e completo nel campo "Server URL" nella maschera di configurazione dell'app di Perfetto.

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A titolo esemplificativo, gli errori più frequenti rilevati in questa fase sono stati:

  • indicare il protocollo HTTPS in luogo del protocollo HTTP o viceversa (ad es. https://88.149.x.x/mago4 al posto di http://88.149.x.x/mago4)
  • omettere l'indicazione del protocollo (HTTP o HTTPS) (ad es. 88.149.x.x/mago4 al posto di http://88.149.x.x/mago4)
  • omettere l'indicazione del nome dell'installazione (ad es. http://88.149.x.x/ al posto di http://88.149.x.x/mago4)
  • omettere l'indicazione di una specifica porta (ad es. http://88.149.x.x/ mago4 al posto di http://88.149.x.x:8080/mago4)

Una volta indicato l'URL corretto, la configurazione dell'app sullo smartphone avviene senza ulteriori problemi e/o errori.

 

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